nvidia-drivers-390.67 vs. kernel 4.17+


I’m not sure whether this is against the 4.17 release or a precursor to 4.18-rc1, but I was welcomed to a small error in my nvidia-installer.log yesterday:

   In file included from /mnt/gentoo/usr/src/linux/include/drm/drmP.h:82:0,
                    from /tmp/selfgz5244/NVIDIA-Linux-x86_64-390.67/kernel/nvidia-drm/nvidia-drm-priv.h:30,
                    from /tmp/selfgz5244/NVIDIA-Linux-x86_64-390.67/kernel/nvidia-drm/nvidia-drm-drv.c:25:
   /tmp/selfgz5244/NVIDIA-Linux-x86_64-390.67/kernel/nvidia-drm/nvidia-drm-drv.c:637:23: error: ‘DRM_CONTROL_ALLOW’ undeclared here (not in a function); did you mean ‘DRM_RENDER_ALLOW’?
                          DRM_CONTROL_ALLOW|DRM_UNLOCKED),
                          ^

It’s a small problem. DRM_CONTROL_ALLOW has been stripped from the kernel. So far I’ve been running stable after just stripping this out.


Leave a Reply